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The software JMP Pro 14 is installed on the Macs of the Phonetics Institute. Private versions can be 
bought from <https://estore.onthehub.com/WebStore/ProductSearchOfferingList.aspx?srch=jmp> 
for €25.30 (6 month license) or €42.20 (12 month license) oder 30 Tage kostenlos asl Testversion 
(https://www.jmp.com/de_de/download-jmp-free-trial.html)

Online documentation can be found on <http://www.jmp.com/support/help/14/> and ‘one page 
guides’, tutorials and demos are on <http://www.jmp.com/en_us/learning-library.html>. It is 
possible to download the manuals with the ‘help’ function in JMP: Use e.g. ’Help → Books’ to get a 
PDF of the specific manual.

JMP is not a spreadsheet program, so many things are different from Excel or Numbers (or alike).

JMP can handle strings (i.e. there is no need to recode things to numbers as in SPSS or R).

Unfortunately, JMP sometimes crashes on complex operations (it seems to be often an out-of-
memory problem). Therefore, it is advisable to save changes or new data from time to time (I do not 
expect it with the simple examples described in this text.)

Missing values are coded by a single dot (.) – any text somewhere in an otherwise numeric column 
changes the whole column to ‘Character - Nominal’; i.e., it is important to change data entries like 
‘- undefined -‘ (from PRAAT), ‘NA’ (from R) to a dot. Furthermore, German decimal commas and 
thousand-separating dots (e.g. from a German Excel version) must be changed to English decimal 
points (and no thousand separators) .

JMP uses its own terminology, which can be a bit confusing at the beginning. The reason is partly 
that its algorithm are based on different principles than e.g. SPSS, and as a an example, there are no 
within or between factors in an ANOVA in JMP. Another important concept of JMP is that it is 
completely data-driven. That is, you cannot ask “compute the average of a some data” but you 
rather say “show me the distribution of some data” and JMP will show the distribution and what is 
associated with it, beside others, the average. This can be very disturbing at the beginning since one 
does not know what is where, but the help function is often actually helpful. Mind though, that JMP 
expects that you know your statistics, so its ‘tutorial’ does e.g. not explain what an ANOVA is.

In general, data should be organized on a line-by-line basis, specifying the data values completely:
Do not cluster the data into groups, which might look more compact to you.

Example how not to do it:

Subject Gender Condition Turn Reactiontime

A1 male filler 1 345.7

A1 male filler 2 517.3

A1 male test 3 413.3

A1 male ctrl 4 749

• • •

Reactiontimes for Subject 

A1, male 345.7 517.3 413.3 749
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There are often small triangles next to headings in JMP. The grey triangles close/open a field, 
whereas clicking the red triangles provides options for a field.

There are many options hidden in the graphs and tables – often it is enough to click in a part of the 
graph or table to get a display of available option. You should also try out to Right Click (or Ctrl 
Click if the Secondary Click is not enabled on your Mac) on parts of the graph or table.

1) Importing data into JMP
JMP expects on an English Operating System numbers with decimal points and not decimal 
commas, on a German Operating System it is the other way round: decimal commas are expected 
for numerical values. I.e., if you want to read on the computer in the Lab data directly from PRAAT 
outputs, you have to convert points to commas; if you use data from a German Excel program you 
can use the data directly.

There are essentially three ways to get data into JMP (other than typing it in directly):

a) Fast: Open the data file with a text editor, separated by tabs. Copy all data. Open JMP and use 
File → New → New Data Table and  Paste the data into the data field. If you have column names, 
use Edit → Past With Column Names.

b) Proper: File → Open…, navigate to your file, select Open As: Data (Best Guess) (option 
underneath the browser window) and click on Open.

c) Controlled: File → Open…, navigate to your file, select Open As: Data (Using Preview) 
(underneath the browser window) and click on Open. 

Grey triangles opens /
closes fields 
(here: ‘File’ is closed, 
‘Distributions’ is open) 

Red triangle shows 
options (some with sub-
options). 
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In the next window you can specify the separator between data columns, whether there is a header 
or not, and others. Once you are happy with the settings, click Next.

You will get another window which gives you instruction how to (not) read in individual columns, 
(re-)name the columns and specify data types. Once you’re happy, click Import.
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2) Specifying data types for columns
JMP uses the data type (Character, Ordinal, Numeric) to determine which statistical procedures are 
appropriate for that type. It is very important to set the correct data type. In the data window (which 
looks like a spreadsheet) double click on the area above the header of a column and you can change/
add the Column Name and specify the Data Type as Character or Numeric (or Row state – which 
we do not handle here). (In case you have clicked on the name of column you can only change the 
name of the column.) The Modeling Type can be Numeric (i.e., the numbers are continuous values 
and all mathematical operations, like arithmetic mean, standard deviation, t-test, ANOVA, etc. can 
be performed with them), Ordinal (i.e, the numbers are ranks, and only Median, Range, etc. can be 
computed), or Nominal (i.e., the numbers are ‘names’ and can only be counted or used as factors in 
a ANOVA). Note that any non-numeric data in an otherwise numeric column forces the whole 
columns to become ‘Character - Nominal’. (Btw., Character data is left aligned, Numeric data is 
right aligned.)

Click into this area  to get 
the window displayed here

Click on the name to only 
change the name of the column
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3) Selecting Data (and some descriptive statistics)1

Analyze → Distribution

After clicking OK you’ll get the ‘Distribution Window’. What you see there depends on the data 
type (e.g. Nominal or Continuous). You can Select data by clicking on or ‘to-the-right’ of the bars; 
ORing (unification) of data by holding the shift key and clicking; NOTing (excluding) of data by 
holding simultaneously the shift- and the ⌘-key and clicking.

 Data is from “Vowels_F1_F2_F3_gender.jmp1

These data are selected 

Basic statistics for Ordinal 
and Continuous data

Basic statistics for Continuous 
data (more under the red triangle)

Percentage of these items in 
the whole data set

Number of items for Nominal data.

2) Drag items into this 
field or use “Y, Columns”

1) Select here what to show
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You can add many more statistics by selecting them from the red triangle menu. You can also 
change the Display Options to e.g. a Horizontal Layout as done in the next screen shot: 

Box plot: Display of box between 25%/75% quartiles with median and ‘whiskers’
Median: ‘middle’ of all values (here: 519)
25% Quartile: 25% of all data are smaller than this value (here: 407)
75% Quartile: 75% of all data are larger than this value (here: 679)
Interquartile range: Range between 25% and 75% quartile (50% of all data around the median)

(here: 407 to 679, range: 272)
Whiskers: 75%/25% quartile ± 1.5*interquartile range (or lowest/highest non-outlier value)

(here: 407 - 1.5*(679-407) = -1, but lowest value is 64, and 679 + 1.5*272 = 1087)
Shortest 50% range: Shortest range where 50% of all data are located.
Mean Conf Diamond: Leaving out 5% of the (lowest) data gives the Upper 95% Mean.

Leaving out 5% of the (highest) data gives the Lower 95% Mean.
The range between these two means shows where the true population mean 
is most likely to be and the diamond illustrates this range. 
(A small diamond indicates that the average (= arithmetic mean) is likely to be a good 
estimation of the ‘real’ average, unaffected by outliers.)

Mean: Arithmetic mean (= average = 1st Moment) �

Std Dev: Standard Deviation (= positive square root of variance) �
Variance: Square of Standard Deviation (= 2nd Moment)
Std Err Mean: Standard Error of the Mean �

CV: Coefficient of Variation: Relation of the Standard Deviation to the Mean in 
Percent – easy way to ‘judge’ whether a Std.Dev. is large or small.

Skewness: Skew of distribution (= 3rd Moment)
(negative values: right shifted, positive values: left shifted distribution)

Kurtosis: (= 4th Moment) ‘Peakedness’ of the distribution (high value: small high 
peak; low value: rather flat distribution)  

x =
xi∑
n

sd =
xi − x( )2∑
n − 1

sterr = sd

n

Shortest range with 50% of all data ‘Whiskers’ (upper quartile + 1.5 * interquartile range) range)

Possible outliers‘Box Plot’ (interquartile range)

‘Mean Confidence Diamond’ (range between up/low 95% mean, looks here like a line)25% Quartile Median

75% Quartile

‘Peakiness’ of distribution 
(small value: more flat, 
large value: more ‘peaky’ 
than normal distribution)‘Percent Coefficient of Variation’

(= 100 * st.dev. / mean)

Skew of distribution (negative values: right 
shifted, positive values: left shifted distribution)
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Double clicking on the scale (here: 0…1200) leads to a window where many parameters for the 
Histogram can be set (linear or log scale, minimum and maximum, number of tics, setting labels, 
etc.).

The ‘Lasso’ on top of the display is a helpful 
tool to ‘catch’ data points (e.g. the outliers in 
the Histogram display.

A helpful information when data is selected is at the lower left 
corner of the original data table, where the number of selected 
data points (i.e. lines in the table) is displayed. All selected data 
is also highlighted in the original data table.

Tables → Subset
The Tables → Subset functions allows to produce a 
new table of copied data selected by clicking on the 
bars in the Analyze windows, data selected with the 
Lasso, or even single data points selected in a table 
or by clicking on points in a display.

Important is here whether all columns will be 
copied to the new table or only those which are 
selected at the moment when the Subset function is 
called.

Another important function is the ‘Link’ option: if 
this box is not selected, the new table is completely 
independent from the original table, and e.g. 
deleting or changing values there has no effect in 
the original table. If this box is checked, on the 
other hand, any action in the new subset will also 
take effect in the original table. This feature is very helpful, if, for example, when you have selected 
outliers with the Lasso and inspect them further in the Subset and you eventually correct or delete 
tehm, then the original table is updated in the same way.

The selection of data was done up to now by visual judgement – the next section will present a 
method that allows exact specification of selection criteria (and much more).  

Lasso

Nr. of selected 
data points

(No) Link

Columns?
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Formula
By double-clicking right from the last column in the data window, or using Cols → New Column… 
you can create a new column. Double-click on the area above the the new Column name and you 
get the window to assign properties for this new column. Change to column name to you liking and 
choose the data type Character (or whatever type of data you want to generate – I will use character 
in this example) and select under Column Properties the type Formula. This will expand the 
window; click then onto Edit Formula. This will open a new formula window where many elements 
become visible to specify how the new column should be filled with data by building a formula, 
which can use information from any of the existing columns (and their values in their rows). On the 
left appear the names of the columns in the data table, on the right there are functions grouped by 
their properties. In the middle are some operators which are often used (important is here the ^ 
which stands for ‘insert’ as you will see below).

In this example I want to select F1 data which is only in a certain range: above or at 150 Hz and 
below 1000 Hz. There are essentially two ways to achieve this: either by using a ‘binary equation’ 
or by using an ‘if…then…else’ statement.

Binary Equation
The statement ‘a F1 value should be above or at 150 Hz and below 1000 Hz’ (i.e. in the range 
150 ≤ F1 < 1000) can be formulated by clicking in the formula window on Comparisons → 
a <= b < c and this ‘formula’ appears in the red marked field. Type 150 into the left and 1000 into 
the right field. Click onto the middle field (marking it red) and click on F1[Hz]. Ready is your 
formula! (In case you hit the formula not at these marked fields, the whole formula or the part 
marked by the grey surrounding will come up as text with the syntax of the formula editor of JMP. 
You can type in the data there as well, and even copy-and-paste it into an text editor and write more 
complex formulas there.) Click on OK (or Apply in case you want to construct more complex 
formulas and see the result at this step) and click OK in the column specification window. The new 
column will be filled with 1s and 0s: 1 means the statement of the formula is true (in our example, 
the F1-data will be between 150 and 1000 Hz), 0 means it is false (i.e., the F1 values are smaller or 
larger). You can construct more complex formulas in many ways, often you will select Comparisons 
or logical operators (and, or, not, etc.) from the Conditional menu.

This opens the window on the right Variable (i.e. column contents) Sets of functions‘Insert’ action
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if…then…else
Very often rather complex re-codings or selections can be achieved with an if…then…else 
construction (the text here sounds much more complicated than it actually is). Select from the 
Function menu the entry Conditional → if. Drag from the Table columns list the column name 
F1[Hz] into the grey expr field, type the greater sign (>) or select it from the Function → 
Comparison menu and type 150 into the right field. Click on the grey surrounding of F1[Hz] > 150. 
This part of the formula should now be marked red, in case you clicked on the part it might come up 
as a text – just click somewhere in the empty formula box to switch back to the normal layout. Once 
the part is marked red select from the Function → Conditional and select and. Now you can build 
the second half of the formula by construction F1[Hz] < 1000. (Note that this formula is slightly 
different from the Binary equation formula!) Click on the grey then clause field and type the double 
quotes followed by e.g. within. The double quotes are essential if you want to insert a character text, 
otherwise JMP will interpret a sequence of characters (= string) as a name of a variable or column 
name. (It is enough to type the initial double-quotes; JMP automatically insert the closing quotes.) 
Insert into the else clause field in the same way “outlier”. When you click on Apply or OK, the new 
column will be filled with within or outlier strings. 

If you want to add more if…then cases to this conditional clause, select the then clause, which 
carries now the string “within” and click on the ^ (insert mark) in the top middle field twice to get 
an additional else clause. (E.g., you could construct something like F1[Hz] >= 1000 ⇒ “above”.)

Additional ‘hidden’ arguments in function
All functions show their standard fields where a variable, usually a column name, can be inserted. 
There are many functions that have more ‘hidden’ fields, which are indicated be a small triangle 
arrow beyond the field where it can be inserted. To access this field you have to highlight (redden) 
the field before and type a comma (,), and the additional field will be inserted. This process can 
continue, as it shown here for the Statistical function Col Mean:

In the next example, the arithmetic mean of F1[Hz] is computed for every Vowel of every Speaker:

Hint:
The string replacement function is hidden in the Character function munger in a hidden field.  

Indicator for ‘hidden’ field


